实验6-9 统计一行文本的单词个数(15 分)

实验6-9 统计一行文本的单词个数(15 分)

本题目要求编写程序统计一行字符中单词的个数。所谓“单词”是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。

输入格式:

输入给出一行字符。

输出格式:

在一行中输出单词个数。

输入样例:

1
Let's go to room 209.

输出样例:

1
5

实验6-8 简单计算器(20 分)

实验6-8 简单计算器(20 分)

模拟简单运算器的工作。假设计算器只能进行加减乘除运算,运算数和结果都是整数,四种运算符的优先级相同,按从左到右的顺序计算。

输入格式:

输入在一行中给出一个四则运算算式,没有空格,且至少有一个操作数。遇等号”=”说明输入结束。

输出格式:

在一行中输出算式的运算结果,或者如果除法分母为0或有非法运算符,则输出错误信息“ERROR”。

输入样例:

1
1+2*10-10/2=

输出样例:

1
10

实验6-7 使用函数输出一个整数的逆序数(20 分)

实验6-7 使用函数输出一个整数的逆序数(20 分)

本题要求实现一个求整数的逆序数的简单函数。

函数接口定义:

1
int reverse( int number );

其中函数reverse须返回用户传入的整型number的逆序数。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include <stdio.h>

int reverse( int number );

int main()
{
int n;

scanf("%d", &n);
printf("%d\n", reverse(n));

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
-12340

输出样例:

1
-4321

实验6-6 使用函数验证哥德巴赫猜想(20 分)

实验6-6 使用函数验证哥德巴赫猜想(20 分)

本题要求实现一个判断素数的简单函数,并利用该函数验证哥德巴赫猜想:任何一个不小于6的偶数均可表示为两个奇素数之和。素数就是只能被1和自身整除的正整数。注意:1不是素数,2是素数。

函数接口定义:

1
2
int prime( int p );
void Goldbach( int n );

其中函数prime当用户传入参数p为素数时返回1,否则返回0;函数Goldbach按照格式“n=p+q”输出n的素数分解,其中p≤q均为素数。又因为这样的分解不唯一(例如24可以分解为5+19,还可以分解为7+17),要求必须输出所有解中p最小的解。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include <stdio.h>
#include <math.h>

int prime( int p );
void Goldbach( int n );

int main()
{
int m, n, i, cnt;

scanf("%d %d", &m, &n);
if ( prime(m) != 0 ) printf("%d is a prime number\n", m);
if ( m < 6 ) m = 6;
if ( m%2 ) m++;
cnt = 0;
for( i=m; i<=n; i+=2 ) {
Goldbach(i);
cnt++;
if ( cnt%5 ) printf(", ");
else printf("\n");
}

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
89 100

输出样例:

1
2
3
89 is a prime number
90=7+83, 92=3+89, 94=5+89, 96=7+89, 98=19+79
100=3+97,

实验6-5 使用函数输出指定范围内的Fibonacci数(20 分)

实验6-5 使用函数输出指定范围内的Fibonacci数(20 分)

本题要求实现一个计算Fibonacci数的简单函数,并利用其实现另一个函数,输出两正整数$m \text{和} n(0 \lt m \leq n\leq 10000)$之间的所有Fibonacci数。所谓Fibonacci数列就是满足任一项数字是前两项的和(最开始两项均定义为1)的数列。

函数接口定义:

1
2
int fib( int n );
void PrintFN( int m, int n );

其中函数fib须返回第n项Fibonacci数;函数PrintFN要在一行中输出给定范围[m, n]内的所有Fibonacci数,相邻数字间有一个空格,行末不得有多余空格。如果给定区间内没有Fibonacci数,则输出一行“No Fibonacci number”。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include <stdio.h>

int fib( int n );
void PrintFN( int m, int n );

int main()
{
int m, n, t;

scanf("%d %d %d", &m, &n, &t);
printf("fib(%d) = %d\n", t, fib(t));
PrintFN(m, n);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

1
20 100 7

输出样例1:

1
2
fib(7) = 13
21 34 55 89

输入样例2:

1
2000 2500 8

输出样例2:

1
2
fib(8) = 21
No Fibonacci number

实验6-4 使用函数输出指定范围内的完数(20 分)

实验6-4 使用函数输出指定范围内的完数(20 分)

本题要求实现一个计算整数因子和的简单函数,并利用其实现另一个函数,输出两正整数$m\text{和}n(0\lt m\leq n\leq 10000)$之间的所有完数。所谓完数就是该数恰好等于除自身外的因子之和。例如:$6=1+2+3$,其中1、2、3为6的因子。

函数接口定义:

1
2
int factorsum( int number );
void PrintPN( int m, int n );

其中函数factorsum须返回int number的因子和;函数PrintPN要逐行输出给定范围[m, n]内每个完数的因子累加形式的分解式,每个完数占一行,格式为“完数 = 因子1 + 因子2 + … + 因子k”,其中完数和因子均按递增顺序给出。如果给定区间内没有完数,则输出一行“No perfect number”。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#include <stdio.h>

int factorsum( int number );
void PrintPN( int m, int n );

int main()
{
int i, m, n;

scanf("%d %d", &m, &n);
if ( factorsum(m) == m ) printf("%d is a perfect number\n", m);
if ( factorsum(n) == n ) printf("%d is a perfect number\n", n);
PrintPN(m, n);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

1
1 30

输出样例1:

1
2
3
4
1 is a perfect number
1 = 1
6 = 1 + 2 + 3
28 = 1 + 2 + 4 + 7 + 14

输入样例2:

1
7 25

输出样例2:

1
No perfect number

实验6-3 使用函数求特殊a串数列和(20 分)

实验6-3 使用函数求特殊a串数列和(20 分)

给定两个均不超过9的正整数$a$和$n$,要求编写函数求$a+aa+aaa++⋯+aa⋯a$($n$个$a$)之和。

函数接口定义:

1
2
int fn( int a, int n );
int SumA( int a, int n );

其中函数fn须返回的是na组成的数字;SumA返回要求的和。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include <stdio.h>

int fn( int a, int n );
int SumA( int a, int n );

int main()
{
int a, n;

scanf("%d %d", &a, &n);
printf("fn(%d, %d) = %d\n", a, n, fn(a,n));
printf("s = %d\n", SumA(a,n));

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
2 3

输出样例:

1
2
fn(2, 3) = 222
s = 246

实验6-2 分类统计字符个数(15 分)

实验6-2 分类统计字符个数(15 分)

本题要求实现一个函数,统计给定字符串中英文字母、空格或回车、数字字符和其他字符的个数。

函数接口定义:

1
void StringCount( char s[] );

其中 char s[] 是用户传入的字符串。函数StringCount须在一行内按照

1
letter = 英文字母个数, blank = 空格或回车个数, digit = 数字字符个数, other = 其他字符个数

的格式输出。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include <stdio.h>
#define MAXS 15

void StringCount( char s[] );
void ReadString( char s[] ); /* 由裁判实现,略去不表 */

int main()
{
char s[MAXS];

ReadString(s);
StringCount(s);

return 0;
}

/* Your function will be put here */

输入样例:

1
2
aZ &
09 Az

输出样例:

1
letter = 4, blank = 3, digit = 2, other = 1

实验5-11 使用函数求最大公约数(10 分)

实验5-11 使用函数求最大公约数(10 分)

本题要求实现一个计算两个数的最大公约数的简单函数。

函数接口定义:

1
int gcd( int x, int y );

其中xy是两个正整数,函数gcd应返回这两个数的最大公约数。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include <stdio.h>

int gcd( int x, int y );

int main()
{
int x, y;

scanf("%d %d", &x, &y);
printf("%d\n", gcd(x, y));

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
32 72

输出样例:

1
8

实验6-1 近似求PI(15 分)

实验6-1 近似求PI(15 分)

本题要求编写程序,根据下式求π的近似值,直到最后一项小于给定精度eps。

$\frac{π}{2} =1+\frac{1!}{3} +\frac{2!}{3\times5} + \frac{3!}{3\times5\times7} +⋯+\frac{i!}{3\times5×⋯×(2\times i+1)} \times⋯$

输入格式:

输入在一行中给出精度eps,可以使用以下语句来读输入:

1
scanf("%le", &eps);

输出格式:

在一行内,按照以下格式输出π的近似值(保留小数点后5位):

1
PI = 近似值

输入样例:

1
1E-5

输出样例:

1
PI = 3.14158
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×