6-7 在一个数组中实现两个堆栈 (20 分)

6-7 在一个数组中实现两个堆栈 (20 分)

本题要求在一个数组中实现两个堆栈。

函数接口定义:

1
2
3
Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

其中Tag是堆栈编号,取1或2;MaxSize堆栈数组的规模;Stack结构定义如下:

1
2
3
4
5
6
7
typedef int Position;
struct SNode {
ElementType *Data;
Position Top1, Top2;
int MaxSize;
};
typedef struct SNode *Stack;

注意:如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;如果某堆栈是空的,则Pop函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include <stdio.h>
#include <stdlib.h>

#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
ElementType *Data;
Position Top1, Top2;
int MaxSize;
};
typedef struct SNode *Stack;

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

Operation GetOp(); /* details omitted */
void PrintStack( Stack S, int Tag ); /* details omitted */

int main()
{
int N, Tag, X;
Stack S;
int done = 0;

scanf("%d", &N);
S = CreateStack(N);
while ( !done ) {
switch( GetOp() ) {
case push:
scanf("%d %d", &Tag, &X);
if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
break;
case pop:
scanf("%d", &Tag);
X = Pop(S, Tag);
if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
break;
case end:
PrintStack(S, 1);
PrintStack(S, 2);
done = 1;
break;
}
}
return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
2
3
4
5
6
7
8
9
10
11
12
5
Push 1 1
Pop 2
Push 2 11
Push 1 2
Push 2 12
Pop 1
Push 2 13
Push 2 14
Push 1 3
Pop 2
End

输出样例:

1
2
3
4
5
6
Stack 2 Empty
Stack 2 is Empty!
Stack Full
Stack 1 is Full!
Pop from Stack 1: 1
Pop from Stack 2: 13 12 11
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
Operation GetOp()
{
char Push[] = "Push";
char Pop[] = "Pop";
char End[] = "End";
char s[100];
scanf("%s", s);

if (strcmp(Push, s) == 0)return push;
if (strcmp(Pop, s) == 0)return pop;
if (strcmp(End, s) == 0)return end;
}
void PrintStack(Stack S, int Tag)
{
printf("Pop from Stack %d:", Tag);
if (Tag == 1){
while (S->Top1 != -1){
printf(" %d", S->Data[S->Top1--]);
}
}
else {
while (S->Top2 != S->MaxSize){
printf(" %d", S->Data[S->Top2++]);
}
}
putchar('\n');
}

Stack CreateStack(int MaxSize)
{
Stack stack = (Stack)malloc(sizeof(struct SNode));
stack->Data = (int *)malloc(sizeof(ElementType)* MaxSize);
stack->Top1 = -1;
stack->Top2 = MaxSize;
stack->MaxSize = MaxSize;
return stack;
}
bool Push(Stack S, ElementType X, int Tag)
{
if (S == NULL)return false;
if (S->Top1+1==S->Top2){
printf("Stack Full\n");
return false;
}

if (Tag == 1)
S->Data[++S->Top1] = X;
else S->Data[--S->Top2] = X;
return true;
}
ElementType Pop(Stack S, int Tag)
{
if (S == NULL)return ERROR;
if (Tag == 1){
if (S->Top1 == -1)
{
printf("Stack %d Empty\n",Tag);
return ERROR;
}
return S->Data[S->Top1--];
}

if (S->Top2 == S->MaxSize)
{
printf("Stack %d Empty\n", Tag);
return ERROR;
}
return S->Data[S->Top2++];


}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×