7-34 通讯录的录入与显示(10 分)

7-34 通讯录的录入与显示(10 分)

通讯录中的一条记录包含下述基本信息:朋友的姓名、出生日期、性别、固定电话号码、移动电话号码。 本题要求编写程序,录入N条记录,并且根据要求显示任意某条记录。

输入格式:

输入在第一行给出正整数$N(\leq 10)$;随后N行,每行按照格式姓名 生日 性别 固话 手机给出一条记录。其中姓名是不超过10个字符、不包含空格的非空字符串;生日按yyyy/mm/dd的格式给出年月日;性别用M表示“男”、F表示“女”;固话手机均为不超过15位的连续数字,前面有可能出现+

在通讯录记录输入完成后,最后一行给出正整数K,并且随后给出K个整数,表示要查询的记录编号(从0到N−1顺序编号)。数字间以空格分隔。

输出格式:

对每一条要查询的记录编号,在一行中按照姓名 固话 手机 性别 生日的格式输出该记录。若要查询的记录不存在,则输出Not Found

输入样例:

1
2
3
4
5
3
Chris 1984/03/10 F +86181779452 13707010007
LaoLao 1967/11/30 F 057187951100 +8618618623333
QiaoLin 1980/01/01 M 84172333 10086
2 1 7

输出样例:

1
2
LaoLao 057187951100 +8618618623333 F 1967/11/30
Not Found
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
#include<stdio.h>
#include<stdlib.h>

typedef struct node{
char name[11];
char birthday[11];
char sex;
char num[17];
char phone[17];
struct node* next;
}type;

void output(type* head,int N);
type* input(int N);

int main(void)
{
type *head;
int N;
//int i=0,j=0;
scanf("%d",&N);
head=input(N);
output(head,N);
return 0;
}

type* input(int N)
{
type *p,*q,*head;
int i=0;
p=q=(type*)malloc(sizeof(type));
for(i=0;i<N;i++) {
scanf("%s %s %c %s %s\n",p->name,p->birthday,&(p->sex),p->num,p->phone);
if(i==0) {
head=p;
} else {
q->next=p;
}
q=p;
p=(type*)malloc(sizeof(type));
}
q->next=NULL;
p->next=NULL;
return head;
}

void output(type* head,int N)
{
int K,i,j;
scanf("%d",&K);
int a[K];
type *q;
//p=q=(type*)malloc(sizeof(type));
for(i=0;i<K;i++) {
scanf("%d",&a[i]);
}

for(i=0;i<K;i++) {
if(a[i]<N&&a[i]>=0) {
q=head;
for(j=0;j<a[i];j++) {
q=q->next;
}
printf("%s %s %s %c %s\n",q->name,q->num,q->phone,q->sex,q->birthday);
} else {
printf("Not Found\n");
}

}
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×