7-29 删除字符串中的子串(20 分)

7-29 删除字符串中的子串(20 分)

输入2个字符串S1和S2,要求删除字符串S1中出现的所有子串S2,即结果字符串中不能包含S2。

输入格式:

输入在2行中分别给出不超过80个字符长度的、以回车结束的2个非空字符串,对应S1和S2。

输出格式:

在一行中输出删除字符串S1中出现的所有子串S2后的结果字符串。

输入样例:

1
2
Tomcat is a male ccatat
cat

输出样例:

1
Tom is a male
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include <stdio.h>

char s1[80]={""};
char s2[80]={""};
int main()
{
int i,j;
int m=0;//s1共输入m个字符
int n=0;//s2共输入n个字符
int comp=0;//用于标记是否重复
int a,b;
int c;
for(i=0;;i++){
scanf("%c",&s1[i]);
if(s1[i]=='\n'){
break;
}
m++;
}
for(j=0;;j++){
scanf("%c",&s2[j]);
if(s2[j]=='\n'){
break;
}
n++;
}
for(a=0;a<m;a++){
if(s1[a]==s2[0]){
comp=1;
}
for(b=0;b<=n-1;b++){
if(s1[a+b]!=s2[b]){
comp=0;
}
}
if(comp==1){
m=m-n;
for(c=a;c<m;c++){
s1[c]=s1[c+n];
}
a=-1;//此处a=-1而不是0,防止s1数组初始位置开始即与s2重合
s1[m]='\0';
comp=0;
}
}
for(int i=0;i<m;i++){
printf("%c",s1[i]);
}
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×