7-16 求符合给定条件的整数集(15 分)

7-16 求符合给定条件的整数集(15 分)

给定不超过6的正整数A,考虑从A开始的连续4个数字。请输出所有由它们组成的无重复数字的3位数。

输入格式:

输入在一行中给出A。

输出格式:

输出满足条件的的3位数,要求从小到大,每行6个整数。整数间以空格分隔,但行末不能有多余空格。

输入样例:

1
2

输出样例:

1
2
3
4
234 235 243 245 253 254
324 325 342 345 352 354
423 425 432 435 452 453
523 524 532 534 542 543
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include <stdio.h>
int main()
{
int start;
scanf("%d", &start);
int end;
int n = 0;
end = start + 4;
for(int i = start; i<end; i++){
for(int j = start; j<end; j++){
if(i == j) continue;
for(int k = start; k<end; k++){
if(k == j) continue;
if(k == i) continue;
n++;
if(n%6){
printf("%d ", i*100+j*10+k);
}else{
printf("%d\n", i*100+j*10+k);
}
}
}
}
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×