6-9 统计个位数字(15 分)

6-9 统计个位数字(15 分)

本题要求实现一个函数,可统计任一整数中某个位数出现的次数。例如-21252中,2出现了3次,则该函数应该返回3。

函数接口定义:

1
int Count_Digit ( const int N, const int D );

其中ND都是用户传入的参数。N的值不超过int的范围;D是[0, 9]区间内的个位数。函数须返回ND出现的次数。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <stdio.h>

int Count_Digit ( const int N, const int D );

int main()
{
int N, D;

scanf("%d %d", &N, &D);
printf("%d\n", Count_Digit(N, D));
return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
-21252 2

输出样例:

1
3
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include <stdio.h>

int Count_Digit ( const int N, const int D );

int main()
{
int N, D;

scanf("%d %d", &N, &D);
printf("%d\n", Count_Digit(N, D));
return 0;
}
int Count_Digit ( const int N, const int D )
{
int a[10] = {0},n = N;
if(n<0)
n = -n;
else if(n==0)
return 1;
while(n)
{
a[n%10]++;
n/=10;
}
return a[D];
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×