6-7 统计某类完全平方数(20 分)
本题要求实现一个函数,判断任一给定整数N
是否满足条件:它是完全平方数,又至少有两位数字相同,如144、676等。
函数接口定义:
1
| int IsTheNumber ( const int N );
|
其中N
是用户传入的参数。如果N
满足条件,则该函数必须返回1,否则返回0。
裁判测试程序样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21
| #include <stdio.h> #include <math.h>
int IsTheNumber ( const int N );
int main() { int n1, n2, i, cnt; scanf("%d %d", &n1, &n2); cnt = 0; for ( i=n1; i<=n2; i++ ) { if ( IsTheNumber(i) ) cnt++; } printf("cnt = %d\n", cnt);
return 0; }
|
输入样例:
输出样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
| #include <stdio.h> #include <math.h>
int IsTheNumber ( const int N );
int main() { int n1, n2, i, cnt; scanf("%d %d", &n1, &n2); cnt = 0; for ( i=n1; i<=n2; i++ ) { if ( IsTheNumber(i) ) cnt++; } printf("cnt = %d\n", cnt);
return 0; }
int IsTheNumber ( const int N ) { int n,m; n=(int)sqrt(N); m=n*n; if(m==N) { int num[10]={0}; int i; while(m>0) { for(i=0;i<=9;i++) { if(m%10==i) { num[i]+=1; if(num[i]==2) { return 1; } } } m=m/10; } return 0; } return 0; }
|