6-2 多项式求值(15 分)

6-2 多项式求值(15 分)

本题要求实现一个函数,计算阶数为n,系数为a[0]a[n]的多项式$f(x)=\sum_{i=0}^{n}\left(a[i] \times x^{i}\right)$在x点的值。

函数接口定义:

1
double f( int n, double a[], double x );

其中n是多项式的阶数,a[]中存储系数,x是给定点。函数须返回多项式f(x)的值。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
#include <stdio.h>

#define MAXN 10

double f( int n, double a[], double x );

int main()
{
int n, i;
double a[MAXN], x;

scanf("%d %lf", &n, &x);
for ( i=0; i<=n; i++ )
scanf(“%lf”, &a[i]);
printf("%.1f\n", f(n, a, x));
return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
2
2 1.1
1 2.5 -38.7

输出样例:

1
-43.1
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
#include <stdio.h>

#define MAXN 10

double f( int n, double a[], double x );

int main()
{
int n, i;
double a[MAXN], x;

scanf("%d %lf", &n, &x);
for ( i=0; i<=n; i++ )
scanf("%lf", &a[i]);
printf("%.1f\n", f(n, a, x));
return 0;
}

double f( int n, double a[], double x )
{
int i;
double b=1.0;
double sum=a[0];
for(i=1;i<=n;i++)
{
b=b*x;
sum=sum+b*a[i];
}
return sum;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×