习题9-5 通讯录排序(20 分)

习题9-5 通讯录排序(20 分)

输入n个朋友的信息,包括姓名、生日、电话号码,本题要求编写程序,按照年龄从大到小的顺序依次输出通讯录。题目保证所有人的生日均不相同。

输入格式:

输入第一行给出正整数$n(\lt 10)$。随后n行,每行按照“姓名 生日 电话号码”的格式给出一位朋友的信息,其中“姓名”是长度不超过10的英文字母组成的字符串,“生日”是yyyymmdd格式的日期,“电话号码”是不超过17位的数字及+-组成的字符串。

输出格式:

按照年龄从大到小输出朋友的信息,格式同输出。

输入样例:

1
2
3
4
3
zhang 19850403 13912345678
wang 19821020 +86-0571-88018448
qian 19840619 13609876543

输出样例:

1
2
3
wang 19821020 +86-0571-88018448
qian 19840619 13609876543
zhang 19850403 13912345678
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include <stdio.h>
#include <string.h>
struct contact {
char name[10];
int birthday;
char telephoneNumber[17];
};

int main()
{
int i, index, j, n;
struct contact friend[10], temp;

scanf("%d", &n);
for (i=0; i<n; i++)
scanf("%s %d %s", friend[i].name, &friend[i].birthday, friend[i].telephoneNumber);

for (i=0; i<n-1; i++)
{
index=i;
for (j=i+1; j<n; j++)
if (friend[index].birthday > friend[j].birthday)
index=j;
temp=friend[index];
friend[index]=friend[i];
friend[i]=temp;
}

for (i=0; i<n; i++)
printf("%s %d %s\n", friend[i].name, friend[i].birthday, friend[i].telephoneNumber);

return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×