习题9-3 平面向量加法(15 分)

习题9-3 平面向量加法(15 分)

本题要求编写程序,计算两个二维平面向量的和向量。

输入格式:

输入在一行中按照 “$ x_{1} y_{1} x_{2} y_{2}$ ”的格式给出两个二维平面向量$v_{1}=\left(x_{1}, y_{1}\right)$和$v_{2}=\left(x_{2}, y_{2}\right)$的分量。

输出格式:

在一行中按照(x, y)的格式输出和向量,坐标输出小数点后一位(注意不能输出−0.0)。

输入样例:

1
3.5 -2.7 -13.9 8.7

输出样例:

1
(-10.4, 6.0)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include<stdio.h>
int main()
{
struct xy{
double x;
double y;
};
struct xy a,b,c;
int i,j;
scanf("%lf%lf%lf%lf",&a.x,&a.y,&b.x,&b.y);
c.x=a.x+b.x;
c.y=a.y+b.y;
if(c.x<0&&c.x>-0.05) c.x=0.0;
if(c.y<0&&c.y>-0.05) c.y=0.0;
printf("(%.1lf, %.1lf)\n",c.x,c.y);
return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×