习题9-2 计算两个复数之积(15 分)

习题9-2 计算两个复数之积(15 分)

本题要求实现一个计算复数之积的简单函数。

函数接口定义:

1
struct complex multiply(struct complex x, struct complex y);

其中struct complex是复数结构体,其定义如下:

1
2
3
4
struct complex{
int real;
int imag;
};

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#include <stdio.h>

struct complex{
int real;
int imag;
};

struct complex multiply(struct complex x, struct complex y);

int main()
{
struct complex product, x, y;

scanf("%d%d%d%d", &x.real, &x.imag, &y.real, &y.imag);
product = multiply(x, y);
printf("(%d+%di) * (%d+%di) = %d + %di\n",
x.real, x.imag, y.real, y.imag, product.real, product.imag);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
3 4 5 6

输出样例:

1
(3+4i) * (5+6i) = -9 + 38i
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
#include <stdio.h>

struct complex{
int real;
int imag;
};

struct complex multiply(struct complex x, struct complex y);

int main()
{
struct complex product, x, y;

scanf("%d%d%d%d", &x.real, &x.imag, &y.real, &y.imag);
product = multiply(x, y);
printf("(%d+%di) * (%d+%di) = %d + %di\n",
x.real, x.imag, y.real, y.imag, product.real, product.imag);

return 0;
}
struct complex multiply(struct complex x, struct complex y)
{
struct complex result;
result.real = x.real*y.real - x.imag*y.imag;
result.imag = x.imag*y.real + x.real*y.imag;
return result;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×