习题6-1 分类统计字符个数(15 分)
本题要求实现一个函数,统计给定字符串中英文字母、空格或回车、数字字符和其他字符的个数。
函数接口定义:
1
| void StringCount( char s[] );
|
其中 char s[]
是用户传入的字符串。函数StringCount
须在一行内按照
1
| letter = 英文字母个数, blank = 空格或回车个数, digit = 数字字符个数, other = 其他字符个数
|
的格式输出。
裁判测试程序样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
| #include <stdio.h> #define MAXS 15
void StringCount( char s[] ); void ReadString( char s[] );
int main() { char s[MAXS];
ReadString(s); StringCount(s);
return 0; }
|
输入样例:
输出样例:
1
| letter = 4, blank = 3, digit = 2, other = 1
|
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
| #include <stdio.h> #define MAXS 15
void StringCount( char s[] ); void ReadString( char s[] );
int main() { char s[MAXS];
ReadString(s); StringCount(s);
return 0; } void ReadString(char s[]){ gets(s); } void StringCount(char s[]){ int letter=0,blank=0,digit=0,other=0; int i; for(i=0;s[i]!='\0';i++){ if(s[i]>='A'&&s[i]<='Z'||s[i]>='a'&&s[i]<='z'){ letter++; }else if(s[i]==' '||s[i]=='\n'){ blank++; }else if(s[i]>='0'&&s[i]<='9'){ digit++; }else other++; } printf("letter = %d,blank = %d,digit = %d, other = %d\n",letter,blank,digit,other); }
|