练习7-9 计算天数(15 分)

练习7-9 计算天数(15 分)

本题要求编写程序计算某年某月某日是该年中的第几天。

输入格式:

输入在一行中按照格式“yyyy/mm/dd”(即“年/月/日”)给出日期。注意:闰年的判别条件是该年年份能被4整除但不能被100整除、或者能被400整除。闰年的2月有29天。

输出格式:

在一行输出日期是该年中的第几天。

输入样例1:

2009/03/02

输出样例1:

61

输入样例2:

2000/03/02

输出样例2:

62

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
#include<stdio.h>
int main(int argc, const char * argv[])
{
int year,month,day,i,num=0;
int m[12]={31,28,31,30,31,30,31,31,30,31,30,31};
scanf("%d/%d/%d",&year,&month,&day);
if(((year%4==0)&&(year%100!=0))||(year%400==0))
{
if(month>2)
num=1;
}
for(i=0;i<(month-1);i++)
{
num+=m[i];
}
num=num+day;
printf("%d",num);
return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×