练习5-3 数字金字塔(15 分)

练习5-3 数字金字塔(15 分)

本题要求实现函数输出n行数字金字塔。

函数接口定义:

1
void pyramid( int n );

其中n是用户传入的参数,为[1, 9]的正整数。要求函数按照如样例所示的格式打印出n行数字金字塔。注

意每个数字后面跟一个空格。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include <stdio.h>

void pyramid( int n );

int main()
{
int n;

scanf("%d", &n);
pyramid(n);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
5

输出样例:

1
2
3
4
5
    1 
2 2
3 3 3
4 4 4 4
5 5 5 5 5
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include <stdio.h>

void pyramid( int n );

int main()
{
int n;

scanf("%d", &n);
pyramid(n);

return 0;
}
void pyramid(int n)
{
int i, j;
for (i=1; i<=n; i++)
{
for (j=1; j<=n-i; j++)
printf(" ");
for (j=1; j<=i; j++)
printf("%d ", i);
putchar('\n');
}
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×