练习2-8 计算摄氏温度(10 分)

练习2-8 计算摄氏温度(10 分)

给定一个华氏温度F,本题要求编写程序,计算对应的摄氏温度C。计算公式:$C=5\times(F−32)\div9$。题目保证输入与输出均在整型范围内。

输入格式:

输入在一行中给出一个华氏温度。

输出格式:

在一行中按照格式“Celsius = C”输出对应的摄氏温度C的整数值。

输入样例:

1
150

输出样例:

1
Celsius = 65
1
2
3
4
5
6
7
8
9
10
#include<stdio.h> 
int main(void)
{
int celsius, fahr;
while ( scanf( "%d", &fahr ) != EOF ) {
celsius = 5 *( fahr - 32 )/ 9;
printf("Celsius = %d\n", celsius);
}
return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×