实验11-2-8 单链表结点删除(20 分)

实验11-2-8 单链表结点删除(20 分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中所有存储了某给定值的结点删除。链表结点定义如下:

1
2
3
4
struct ListNode {
int data;
ListNode *next;
};

函数接口定义:

1
2
struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );

函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deletem将单链表L中所有存储了m的结点删除。返回指向结果链表头结点的指针。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
void printlist( struct ListNode *L )
{
struct ListNode *p = L;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}

int main()
{
int m;
struct ListNode *L = readlist();
scanf("%d", &m);
L = deletem(L, m);
printlist(L);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
2
10 11 10 12 10 -1
10

输出样例:

1
11 12
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
void printlist( struct ListNode *L )
{
struct ListNode *p = L;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}

int main()
{
int m;
struct ListNode *L = readlist();
scanf("%d", &m);
L = deletem(L, m);
printlist(L);

return 0;
}

void PushBack(int X, struct ListNode **rear)
{
struct ListNode *TmpCell;

TmpCell = malloc(sizeof(struct ListNode));

TmpCell->data = X;
TmpCell->next = NULL;
(*rear)->next = TmpCell;
*rear = TmpCell;
}

struct ListNode *readlist()
{
struct ListNode *TmpCell, *head, *tail;
int data;

head = tail = malloc(sizeof(struct ListNode));
head->next = NULL;

scanf("%d", &data);
while (data != -1) {
PushBack(data, &tail);
scanf("%d", &data);
}

TmpCell = head;
head = head->next;
free(TmpCell);

return head;
}

struct ListNode *deletem(struct ListNode *L, int m)
{
struct ListNode *head, *p, *TmpCell;

p = head = malloc(sizeof(struct ListNode));
head->next = NULL;

p->next = L;
while (p->next != NULL) {
if (p->next->data == m) {
TmpCell = p->next;
p->next = TmpCell->next;
free(TmpCell);
} else
p = p->next;
}

TmpCell = head;
head = head->next;
free(TmpCell);

return head;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×