实验11-2-4 删除单链表偶数节点(20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
1 2 3 4
| struct ListNode { int data; struct ListNode *next; };
|
函数接口定义:
1 2
| struct ListNode *createlist(); struct ListNode *deleteeven( struct ListNode *head );
|
函数createlist
从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven
将单链表head
中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32
| #include <stdio.h> #include <stdlib.h>
struct ListNode { int data; struct ListNode *next; };
struct ListNode *createlist(); struct ListNode *deleteeven( struct ListNode *head ); void printlist( struct ListNode *head ) { struct ListNode *p = head; while (p) { printf("%d ", p->data); p = p->next; } printf("\n"); }
int main() { struct ListNode *head;
head = createlist(); head = deleteeven(head); printlist(head);
return 0; }
|
输入样例:
输出样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76
| #include <stdio.h> #include <stdlib.h>
struct ListNode { int data; struct ListNode *next; };
struct ListNode *createlist(); struct ListNode *deleteeven( struct ListNode *head ); void printlist( struct ListNode *head ) { struct ListNode *p = head; while (p) { printf("%d ", p->data); p = p->next; } printf("\n"); }
int main() { struct ListNode *head;
head = createlist(); head = deleteeven(head); printlist(head);
return 0; } struct ListNode *createlist() { struct ListNode *p,*h,*q; p=q=(struct ListNode*)malloc(sizeof(struct ListNode)); h=(struct ListNode*)malloc(sizeof(struct ListNode)); int data; h=p; scanf("%d",&data); while(data!=-1) { p->data=data; q->next=p; q=p; p=(struct ListNode*)malloc(sizeof(struct ListNode)); scanf("%d",&data); } q->next=NULL; free(p); return h; } struct ListNode *deleteeven( struct ListNode *head ) { struct ListNode *p,*q; p=q=(struct ListNode*)malloc(sizeof(struct ListNode)); p=head; q->next=p; while(p!=NULL) { if(!(p->data%2)) { if(p==head) { head=head->next; p=head; q->next=p; continue; } q->next=p->next; } else q=p; p=p->next; } free(p); return head; }
|