实验11-2-4 删除单链表偶数节点(20 分)

实验11-2-4 删除单链表偶数节点(20 分)

本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:

1
2
3
4
struct ListNode {
int data;
struct ListNode *next;
};

函数接口定义:

1
2
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );

函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。

函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}

int main()
{
struct ListNode *head;

head = createlist();
head = deleteeven(head);
printlist(head);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
1 2 2 3 4 5 6 7 -1

输出样例:

1
1 3 5 7
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
#include <stdio.h>
#include <stdlib.h>

struct ListNode {
int data;
struct ListNode *next;
};

struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}

int main()
{
struct ListNode *head;

head = createlist();
head = deleteeven(head);
printlist(head);

return 0;
}
struct ListNode *createlist()
{
struct ListNode *p,*h,*q;
p=q=(struct ListNode*)malloc(sizeof(struct ListNode));
h=(struct ListNode*)malloc(sizeof(struct ListNode));
int data; //存放数据
h=p; //h为头节点
scanf("%d",&data);
while(data!=-1)
{
p->data=data; //保存数据
q->next=p; //p指向下一个节点
q=p;
p=(struct ListNode*)malloc(sizeof(struct ListNode));
scanf("%d",&data);
}
q->next=NULL; //尾节点Next指向空
free(p);
return h;
}
struct ListNode *deleteeven( struct ListNode *head )
{
struct ListNode *p,*q;
p=q=(struct ListNode*)malloc(sizeof(struct ListNode));
p=head;
q->next=p;
while(p!=NULL)
{
if(!(p->data%2)) //能被二整除的为偶数
{
if(p==head) //如果p是第一个节点就删除头节点,保留头指向的下一个节点作为头
{
head=head->next;
p=head;
q->next=p;
continue;
}
q->next=p->next; //直接跳过偶数节点
}
else //缺少else会导致重复偶数删除不了
q=p;
p=p->next;
}
free(p);
return head;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×