实验11-2-3 逆序数据建立链表(20 分)
本题要求实现一个函数,按输入数据的逆序建立一个链表。
函数接口定义:
1
| struct ListNode *createlist();
|
函数createlist
利用scanf
从输入中获取一系列正整数,当读到−1时表示输入结束。按输入数据的逆序建立一个链表,并返回链表头指针。链表节点结构定义如下:
1 2 3 4
| struct ListNode { int data; struct ListNode *next; };
|
裁判测试程序样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
| #include <stdio.h> #include <stdlib.h>
struct ListNode { int data; struct ListNode *next; };
struct ListNode *createlist();
int main() { struct ListNode *p, *head = NULL;
head = createlist(); for ( p = head; p != NULL; p = p->next ) printf("%d ", p->data); printf("\n");
return 0; }
|
输入样例:
输出样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
| #include <stdio.h> #include <stdlib.h>
struct ListNode { int data; struct ListNode *next; };
struct ListNode *createlist();
int main() { struct ListNode *p, *head = NULL;
head = createlist(); for ( p = head; p != NULL; p = p->next ) printf("%d ", p->data); printf("\n");
return 0; }
struct ListNode *createlist() { struct ListNode *head = NULL, *now = NULL; int a; while (1) { scanf("%d", &a); if (a == -1)return head; now = (struct ListNode*)malloc(sizeof(struct ListNode)); now->data = a; now->next = head; head = now; } }
|