实验11-1-9 藏尾诗(20 分)

实验11-1-9 藏尾诗(20 分)

本题要求编写一个解密藏尾诗的程序。

输入格式:

输入为一首中文藏尾诗,一共四句。每句一行,但句子不一定是等长的,最短一个汉字,最长九个汉字。注意:一个汉字占两个字节。

输出格式:

取出每句的最后一个汉字并连接在一起形成一个字符串并输出。同时在末尾输入一个换行符。

输入样例:

1
2
3
4
悠悠田园风
然而心难平
兰花轻涌浪
兰香愈幽静

输出样例:

1
风平浪静
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include <stdio.h>
#include <stdlib.h>
#include "math.h"
#include "string.h"

int main()
{
char *p[4],str[20];
int i;
for(i=0;i<=3;i++){
gets(str);
p[i]=(char *)malloc(sizeof(str)+1);
strcpy(p[i],str);

}

int n;

for(i=0;i<=3;i++){
n=strlen(p[i]);
printf("%s",p[i]+n-2);
}

return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×