实验11-1-2 输出月份英文名(15 分)

实验11-1-2 输出月份英文名(15 分)

本题要求实现函数,可以返回一个给定月份的英文名称。

函数接口定义:

1
char *getmonth( int n );

函数getmonth应返回存储了n对应的月份英文名称的字符串头指针。如果传入的参数n不是一个代表月份的数字,则返回空指针NULL。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#include <stdio.h>

char *getmonth( int n );

int main()
{
int n;
char *s;

scanf("%d", &n);
s = getmonth(n);
if ( s==NULL ) printf("wrong input!\n");
else printf("%s\n", s);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

1
5

输出样例1:

1
May

输入样例2:

1
15

输出样例2:

1
wrong input!
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include <stdio.h>

char *getmonth( int n );

int main()
{
int n;
char *s;

scanf("%d", &n);
s = getmonth(n);
if ( s==NULL ) printf("wrong input!\n");
else printf("%s\n", s);

return 0;
}
char *getmonth(int n)
{
char *s[] = {"January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December"};
if(n<=0||n>12)
return NULL;
else
return(s[n-1]);
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×