实验8-1-1 利用指针找最大值(10 分)

实验8-1-1 利用指针找最大值(10 分)

本题要求实现一个简单函数,找出两个数中的最大值。

函数接口定义:

1
void findmax( int *px, int *py, int *pmax );

其中pxpx是用户传入的两个整数的指针。函数findmax应找出两个指针所指向的整数中的最大值,存放在pmax指向的位置。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
#include <stdio.h>

void findmax( int *px, int *py, int *pmax );

int main()
{
int max, x, y;

scanf("%d %d", &x, &y);
findmax( &x, &y, &max );
printf("%d\n", max);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
3 5

输出样例:

1
5
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
#include <stdio.h>

void findmax( int *px, int *py, int *pmax );

int main()
{
int max, x, y;

scanf("%d %d", &x, &y);
findmax( &x, &y, &max );
printf("%d\n", max);

return 0;
}

void findmax( int *px, int *py, int *pmax ){
if(*px>*py)
*pmax=*px;
else
*pmax=*py;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×