实验7-3-9 字符串字母大小写转换(15 分)

实验7-3-9 字符串字母大小写转换(15 分)

本题要求编写程序,对一个以“#”结束的字符串,将其小写字母全部转换成大写字母,把大写字母全部转换成小写字母,其他字符不变输出。

输入格式:

输入为一个以“#”结束的字符串(不超过30个字符)。

输出格式:

在一行中输出大小写转换后的结果字符串。

输入样例:

1
Hello World! 123#

输出样例:

1
hELLO wORLD! 123
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
#include <stdio.h>
#include <string.h>
int main()
{
char str[50];
int i=0,j;
gets(str);
while(str[i]!='#')
{
if(str[i]>='a'&&str[i]<='z')
str[i]=str[i]-32;
else if(str[i]>='A'&&str[i]<='Z')
str[i]=str[i]+32;
i++;
}
for(j=0;j<i;j++)
printf("%c",str[j]);
printf("\n");
return 0;

}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×