实验7-2-7 方阵循环右移(20 分)

实验7-2-7 方阵循环右移(20 分)

本题要求编写程序,将给定n×n方阵中的每个元素循环向右移m个位置,即将第$0、1、⋯、n−1$列变换为第n−m、$n−m+1、⋯、n−1、0、1、⋯、n−m−1$列。

输入格式:

输入第一行给出两个正整数$m和$n(1≤n≤6)$。接下来一共$n$行,每行$n$个整数,表示一个n阶的方阵。

输出格式:

按照输入格式输出移动后的方阵:即输出n行,每行$n$个整数,每个整数后输出一个空格。

输入样例:

1
2
3
4
2 3
1 2 3
4 5 6
7 8 9

输出样例:

1
2
3
2 3 1 
5 6 4
8 9 7
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include <stdio.h>  
int main() {
int a[10][10];
int i,j,n,m;
scanf("%d %d",&m,&n);
for(i=0;i<n;i++) {
for(j=0;j<n;j++) {
scanf("%d",&a[i][j]);
m%=n;
}
}
for(i=0;i<n;i++) {
for(j=0;j<n;j++) {
printf("%d ",a[i][(n-m+j)%n]);
}
printf("\n");
}
return 0;
}
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×