实验6-5 使用函数输出指定范围内的Fibonacci数(20 分)

实验6-5 使用函数输出指定范围内的Fibonacci数(20 分)

本题要求实现一个计算Fibonacci数的简单函数,并利用其实现另一个函数,输出两正整数$m \text{和} n(0 \lt m \leq n\leq 10000)$之间的所有Fibonacci数。所谓Fibonacci数列就是满足任一项数字是前两项的和(最开始两项均定义为1)的数列。

函数接口定义:

1
2
int fib( int n );
void PrintFN( int m, int n );

其中函数fib须返回第n项Fibonacci数;函数PrintFN要在一行中输出给定范围[m, n]内的所有Fibonacci数,相邻数字间有一个空格,行末不得有多余空格。如果给定区间内没有Fibonacci数,则输出一行“No Fibonacci number”。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include <stdio.h>

int fib( int n );
void PrintFN( int m, int n );

int main()
{
int m, n, t;

scanf("%d %d %d", &m, &n, &t);
printf("fib(%d) = %d\n", t, fib(t));
PrintFN(m, n);

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

1
20 100 7

输出样例1:

1
2
fib(7) = 13
21 34 55 89

输入样例2:

1
2000 2500 8

输出样例2:

1
2
fib(8) = 21
No Fibonacci number
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include <stdio.h>
int fib( int n );
void PrintFN( int m, int n );
int main()
{
int m, n, t;
scanf("%d %d %d", &m, &n, &t);
printf("fib(%d) = %d\n", t, fib(t));
PrintFN(m, n);
return 0;
}
int fib( int n )
{
if(n==1||n==2)
{
return 1;
}
if(n>2)
{
return fib(n-1)+fib(n-2);
}
}
void PrintFN( int m, int n )
{
int i=0,j,k=1,count=0;
for(j=0;j<=21;j++)
{
i++;
if(fib(i)>=m&&fib(i)<=n)
{
count++;
printf("%d ",fib(i));
}
}
if(count==0)
{
printf("No Fibonacci number");

}
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×