实验5-6 使用函数判断完全平方数(10 分)
本题要求实现一个判断整数是否为完全平方数的简单函数。
函数接口定义:
其中n
是用户传入的参数,在长整型范围内。如果n
是完全平方数,则函数IsSquare
必须返回1,否则返回0。
裁判测试程序样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
| #include <stdio.h> #include <math.h>
int IsSquare( int n );
int main() { int n;
scanf("%d", &n); if ( IsSquare(n) ) printf("YES\n"); else printf("NO\n");
return 0; }
|
输入样例1:
输出样例1:
输入样例2:
输出样例2:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
| #include <stdio.h> #include <math.h>
int IsSquare( int n );
int main() { int n;
scanf("%d", &n); if ( IsSquare(n) ) printf("YES\n"); else printf("NO\n");
return 0; } int IsSquare( int n ) { int k; k=sqrt(n); if(k*k==n) return 1; else return 0; }
|