实验5-6 使用函数判断完全平方数(10 分)

实验5-6 使用函数判断完全平方数(10 分)

本题要求实现一个判断整数是否为完全平方数的简单函数。

函数接口定义:

1
int IsSquare( int n );

其中n是用户传入的参数,在长整型范围内。如果n是完全平方数,则函数IsSquare必须返回1,否则返回0。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include <stdio.h>
#include <math.h>

int IsSquare( int n );

int main()
{
int n;

scanf("%d", &n);
if ( IsSquare(n) ) printf("YES\n");
else printf("NO\n");

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

1
10

输出样例1:

1
NO

输入样例2:

1
100

输出样例2:

1
YES
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#include <stdio.h>
#include <math.h>

int IsSquare( int n );

int main()
{
int n;

scanf("%d", &n);
if ( IsSquare(n) ) printf("YES\n");
else printf("NO\n");

return 0;
}
int IsSquare( int n ) {
int k;
k=sqrt(n);
if(k*k==n)
return 1;
else
return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×