实验5-2 符号函数(10 分)

实验5-2 符号函数(10 分)

本题要求实现符号函数sign(x)。

函数接口定义:

1
int sign( int x );

其中x是用户传入的整型参数。符号函数的定义为:若x大于0,sign(x) = 1;若x等于0,sign(x) = 0;否则,sign(x) = −1。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include <stdio.h>

int sign( int x );

int main()
{
int x;

scanf("%d", &x);
printf("sign(%d) = %d\n", x, sign(x));

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
10

输出样例:

1
sign(10) = 1
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include <stdio.h>

int sign( int x );

int main()
{
int x;

scanf("%d", &x);
printf("sign(%d) = %d\n", x, sign(x));

return 0;
}
int sign( int x ){
int f;
if(x>0){
f=1;
}
else if(x==0){
f=0;
}else
f=-1;
return f;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×