实验4-2-8 输出整数各位数字(15 分)

实验4-2-8 输出整数各位数字(15 分)

本题要求编写程序,对输入的一个整数,从高位开始逐位分割并输出它的各位数字。

输入格式:

输入在一行中给出一个长整型范围内的非负整数。

输出格式:

从高位开始逐位输出该整数的各位数字,每个数字后面有一个空格。

输入样例:

1
123456

输出样例:

1
1 2 3 4 5 6
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include<stdio.h> 
int main(void) {
long int b,x,t,t1;
scanf("%ld",&x);
if(x<0)
return 0;
else if(x==0)
printf("%d ",x);
else if(x>0) {
t=x%10;
t1=t;
while(x>0) {
x=x/10;
b=x%10;
t=t*10+b;
}
t=t/10;
while(t>0) {
printf("%d ",t%10);
t=t/10;
}
if(t1==0)
printf("0 ");
}
return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×