实验2-4-5 简单实现x的n次方(10 分)

实验2-4-5 简单实现x的n次方(10 分)

本题要求实现一个计算 $x^n(n\geq 0)$的函数。

函数接口定义:

1
double mypow( double x, int n );

函数mypow应返回xn次幂的值。题目保证结果在双精度范围内。

裁判测试程序样例:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
#include <stdio.h>

double mypow( double x, int n );

int main()
{
double x;
int n;

scanf("%lf %d", &x, &n);
printf("%f\n", mypow(x, n));

return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1
0.24 4

输出样例:

1
0.003318
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#include <stdio.h>   
#include <math.h>
double mypow(double x,int n);
int main() {
double x; int n;
scanf("%lf %d", &x, &n);
printf("%f\n", mypow(x, n));
return 0;
}

double mypow(double x,int n){
double r;
r=pow(x,n);
return r;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×