实验2-2-9 计算火车运行时间(15 分)

实验2-2-9 计算火车运行时间(15 分)

本题要求根据火车的出发时间和达到时间,编写程序计算整个旅途所用的时间。

输入格式:

输入在一行中给出2个4位正整数,其间以空格分隔,分别表示火车的出发时间和到达时间。每个时间的格式为2位小时数(00-23)和2位分钟数(00-59),假设出发和到达在同一天内。

输出格式:

在一行输出该旅途所用的时间,格式为“hh:mm”,其中hh为2位小时数、mm为2位分钟数。

输入样例:

1
1201 1530

输出样例:

1
03:29
1
2
3
4
5
6
7
8
9
10
11
12
#include<stdio.h> 
int main(void){
int start,arrive,s,a,m,hh,mm;
scanf("%d%d",&start,&arrive);
s=start/100*60+start%100;
a=arrive/100*60+arrive%100;
m=a-s;
hh=m/60;
mm=m%60;
printf("%02d:%02d",hh,mm);
return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×