实验2-2-1 计算分段函数[1](10 分)

实验2-2-1 计算分段函数[1](10 分)

本题目要求计算下列分段函数f(x)的值:

$$
y=f(x)=\begin{cases}
\frac{1}{x}, & x \neq 0 \\\\
0, & x = 0
\end{cases}
$$
输入格式:

输入在一行中给出实数x。

输出格式:

在一行中按“f(x) = result”的格式输出,其中x与result都保留一位小数。

输入样例1:

1
10

输出样例1:

1
f(10.0) = 0.1

输入样例2:

1
0

输出样例2:

1
f(0.0) = 0.0
1
2
3
4
5
6
7
8
9
10
11
12
13
#include<stdio.h> 
int main(void)
{
float x,y;
scanf("%f",&x);
if(x != 0){
y=1 / x;
}else{
y=0;
}
printf("f(%.1f) = %.1f",x,y);
return 0;
}
Your browser is out-of-date!

Update your browser to view this website correctly. Update my browser now

×